Print Audit Discussion Forum
Sign up Latest Topics
 
 
 


Reply
  Author   Comment  
Steve
 #1 

Hi,


I have a brand new install of Print Audit. On the Ricoh and HP printers  I get the Job Code pop-up and everything works as expected.


When I print to the Epson T5000, whether it's from a Mac or PC I have problems.
On the Mac I do not get a popup and the print job prints.


On the PC I get a popup and enter the Job code. Sometimes the job prints and sometimes I get an error "failed to connect to printer."
After I get the error, I can print to the HP or Ricoh, so the client is not crashing. It just doesn't seem to play nice with the Epson drivers.


Here are the drivers being used:
PC V7.04
Mac V9.33


Any ideas on how to troubleshoot?


 

Print Audit Support
 #2 

Hello Steve,

The tracking client never talks directly to a device, it collects information locally, from the spooler, from the installed driver, and from the application that raised the print event. So an error that indicates "failed to connect to printer" is not coming from the tracking client. That you get a popup means we've collected the information we need to track the job, whether or not the job actually produces output, the client can't know, because it never talks to the device.  We simply write the job to the database, if no output was generated, it would be up to the customer to delete that job using Job Manager.

If this behavior is consistent across multiple machines, that would tend to suggest the driver is the problem, but it sounds like a singular machine is available, so you may want to try addressing the driver as an expedient.  If you aren't using the Universal driver, you might want to try that, generally we steer folks away from the Universal drivers, but to test that the problem lies with the driver...

On the Mac side, particularly if changing the driver on the Windows side seems to have an effect, you might want to try changing drivers, perhaps try the Apple-supplied driver, or any driver that supports the same printer control language used by the device. If you are using the Apple-supplied driver, you could try the one supplied by the manufacturer as well.

Beyond that, we would need to look at logs, and once the issue involves shipping logs, we'll have to move off the support forum, as there is no way for you to upload logs here, so a regular support case would need to be opened with us (Print Audit 6) or Ricoh (PCS Director) as appropriate.

--
Print Audit Support.

Steve
 #3 

Thanks for the response. It appears to be two different problems. Our engineer was able to resolve the problem on the PC's.
Windows 10 has two services that need to be running in order for the job to print properly with PA. The Print Spooler and Printer Extensions and Notifications. On the problem workstations, the second service was set to Manual. Once he started it the print jobs worked as expected.


The Mac's are still not working. I opened a ticket with Ricoh prior to your response. Can you tell me where to collect the logs on a Mac?


Thanks


 

Print Audit Support
 #4 

Hello Steve,

http://kb.printaudit.com/display/PA6/Debug+Logging+for+Print+Audit+6+Mac+Client

That KB article covers setting up logging on the Mac, including where to find the resulting log files.

--
Print Audit Support

Steve
 #5 

Thanks for the KB article. When I get to step 9 there is no "Print Audit 6 Folder." I went ahead and created the folder and was able to capture the PA6ClientError.log. I pasted the pertinent info below.


Aug  2 2016 16:59:54.298 : ClientCommunicationChannel::Accept - accept failed.  Error: Software caused connection abort


Aug  3 2016 11:11:54.348 : ClientCommunicationChannel::Accept - accept failed.  Error: Software caused connection abort


Steve

Print Audit Support
 #6 

Hello Steve,

Error log entries on their own are usually not of much use, the associated Debug logs give the context of those errors, which can often be key in determining where the problem lies.

The KB I pointed you to is really for Print Audit 6, not PCS Director, we don't maintain KB's specific to the Ricoh versions of the product, I would suspect though that instead of the Print Audit 6 folder it would be the PCS Director folder.

Isolated snippets of the log aren't going to work, complete contents of all four of the logs will be required, and as previously indicated the forum isn't really setup for the exchange of logs. 

You will need to work through Ricoh to get this issue resolved.

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.